On Tue, 29 Jul 2003, H.Merijn Brand wrote: > On Tue 29 Jul 2003 16:40, Leopold Toetsch <[EMAIL PROTECTED]> wrote: > > Hi Merijn, > > > HP-UX 11.00/32 2 CPU: > > : > io/io_buf.c > cpp: "io/io_buf.c", line 65: warning 2001: Redefinition of macro MAX. > cpp: "io/io_buf.c", line 66: warning 2001: Redefinition of macro MIN.
The offending lines of io_buf.c are: #define MAX(a, b) ((a) > (b) ? (a) : (b)) #define MIN(a, b) ((a) < (b) ? (a) : (b)) There are a couple of obvious solutions here: i) Rename them to PARROT_MAX, PARROT_MIN ii) Get rid of them. I vote for option (ii), as otherwise someone is likely to write something like: MAX(a,b++) at some point in the future. Now, MAX doesn't appear to be in use at the moment, while MIN is only used in a couple of places, so it shuold be easy to patch this, but I'm going to hold off on doing this until Juergens latest IO patches have been applied. > Scanning /pro/3gl/CPAN/parrot/classes/timer.pmc... > cc -Ae -DDEBUGGING -D_HPUX_SOURCE -Wl,+vnocompatwarnings -I/pro/local/include > -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I../include -o timer.o -c timer.c > cc: "timer.c", line 75: error 1000: Unexpected symbol: "32". > make[1]: *** [timer.o] Error 1 > make[1]: Leaving directory `/pro/3gl/CPAN/parrot/classes' > make: *** [classes/array.o] Error 2 This is odd -- on my machine, line 75 is in the middle of an enum, and looks perfectly fine to me. Could you post the offending section of timer.c? Simon PS Thanks for the report