On Thursday, November 14, 2002, at 11:12  PM, Piers Cawley wrote:

That's not actually what I meant. You use TODO blocks in your test
scripts, like this:

          TODO: {
              local $TODO = "Not yet implemented";
              ok( foo(),       $test_name );
              is( foo(42), 23, $test_name );
          };

perldoc Test::More for more information.
You don't actually have to name the block though. Just assign a
temporary value to TODO.
Ah, I didn't realize that. I think I'd recommend naming it, anyway, just to increase awareness that it is, in fact a TODO block.

Regards,

David

--
David Wheeler AIM: dwTheory
[EMAIL PROTECTED] ICQ: 15726394
http://david.wheeler.net/ Yahoo!: dew7e
Jabber: [EMAIL PROTECTED]

Reply via email to