All -- It seems to me that the full complement of set_* ops should be something like this (minus PMC stuff): set_i_ic # We have this set_i_i # We have this, and call it set_i set_i_nc # NOT NEEDED: Assembler does it set_i_n # We have this, and call it ntoi_i_n set_i_sc # NOT NEEDED: Assembler does it (or complains) set_i_s # We don't have this set_n_ic # NOT NEEDED: Assembler does it set_n_i # We have this, and call it iton_n_i set_n_nc # We have this set_n_n # We don't have this set_n_sc # NOT NEEDED: Assembler does it (or complains) set_n_s # We don't have this set_s_ic # NOT NEEDED: Assembler does it set_s_i # We don't have this set_s_nc # NOT NEEDED: Assembler does it set_s_n # We don't have this set_s_sc # We have this set_s_s # We don't have this I'd like to see the *to* ops renamed according to this plan for symmetry reasons. "Set" is taken to mean: "load, copy or convert". ---------- The relational operator list is incomplete. It should contain all of: {eq,ne,lt,le,gt,ge}_[i_ic,i_i,n_nc,n_n,s_sc,s_s]_ic_ic I also wonder if we could do away with the _ic (_ic_ic here) suffix from the official op names for ops that take "Destinations". ---------- We have if_[in]_ic, but not if_s_ic. ---------- We have print_[ins]c?, but string versions are grouped with string ops and integer and numeric versions are grouped with miscellaneous. ---------- We have end == 0 (MINOP). Should we have noop (nop?) == MAXOP? ---------- Isn't branch_ic just jump_ic? Do we really need a separate root? They both do relative jumps, right? Regards, -- Gregor _____________________________________________________________________ / perl -e 'srand(-2091643526); print chr rand 90 for (0..4)' \ Gregor N. Purdy [EMAIL PROTECTED] Focus Research, Inc. http://www.focusresearch.com/ 8080 Beckett Center Drive #203 513-860-3570 vox West Chester, OH 45069 513-860-3579 fax \_____________________________________________________________________/