Good idea, I'm going to nitpick a few names now...
> =item C<stat>/C<lstat>
>
> 'blksize' Preferred block size for file system I/O
> 'blocks' Actual number of blocks allocated
Either "blocks" and "blocksize", or "blks" and "blksize", I think
> =item C<getpw*>
>
> 'name' Username
I'd really like this to be 'user', but it makes it inconsistent with the
other functions, so either way.
> 'dir' Home directory
'homedir' or 'home' are _much_ better for us sysadmins...
> =item C<gethost*>
>
> 'aliases' Other host names
An array/arrayref (I hope)?
> 'addrtype' Host address type
> 'length' Length of address
> 'addrs' Anonymous array of raw addresses in 'C4' format
Y'know, this C-based interface has always sucked. You know what I always
need to do? This:
my @ips = @{ gethostbyname('bob')->{ipaddrs} };
I know this isn't directly related to your RFC, but I needed to bring it
up. Seems like adding the upack('C4') thing to the gethost* functions
wouldn't be that hard and would make these common tasks a lot easier.
-Nate