MARC::BBMARC has not been updated this time, but I have some subroutines in an internal module (MARC::QBI::Misc) dealing with file handling (to reduce overwriting existing files) and prompting, which I may include in a future version of MARC::BBMARC (even though these are general subroutines, not really related to MARC, hence the reason for not including them in MARC::BBMARC in the first place).
Changes are outlined below; see my home page for more information (including new and updated scripts):
MARC::Errorchecks:
Version 1.07: Updated Dec. 11-Feb. 2005. Released Feb. 13, 2005.
-check_double_periods() skips field 856, where multiple punctuation is possible for URIs.
-added code in check_internal_spaces() to account for spaces between angle brackets in open dates in field 260c.
-Updated various subs to verify that 008 exists (and quietly return if not. check_008 will report the error).
-Changed #! line, removed -w, replaced with use warnings.
-Added error message to check_bk008_vs_bibrefandindex($record) if 008 book
index byte is not 0 or 1. This will result in duplicate errors if check_008 is
also called on the record.
MARC::Lintadditions:
Version 1.07: Updated Jan. 2-Feb. 1, 2005. Released Feb. 13, 2005.
-Updated check_260 to account for angle brackets for open dates in subfield c.
-Updated check_020 to handle 13-digit ISBNs. This relies upon the new internal _isbn13_check_digit($ean), temporary until Business::ISBN handles 13-digit ISBNs directly.
-Added basic check to check_600 (and by call, other 6xx) for subfield 2 codes. Similar code duplicated in check_655, due to difference in code lists for each field. Still need to deal with obsolete code error reporting.
-Moved check_245 to MARC::Lint (retained here as a POD section during testing).
-Moved check_041 and check_043 to MARC::Lint (retained here as a POD section during testing).
-Added warning to check_007 for obsolete byte 2.
-Removed pod info related to changes needed to MARC::Lint (which has been updated).
-Misc. cleanup.
-Revised check_1xx, check_6xx, check_7xx, and check_8xx to use check_100, etc. (to avoid code duplication).
(based on code from Ian Hamilton)
MARC::Lint::CodeData:
Version 1.01: Updated Jan. 5-Feb. 10, 2005. Released (to CPAN) Feb. 13, 2005 (with new version of MARC::Errorchecks).
-Added code list data for 600-651 subfield 2 and for 655 subfield 2 sources.
-Updated codes based on changes made Jan. 19 (languages), Feb. 2 (sources), Feb. 9 (sources).
Version 1.00 (original version): First release, Dec. 5, 2004. Uploaded to SourceForge CVS, Jan. 3, 2005.
-Included in MARC::Errorchecks distribution on CPAN.
-Used by MARC::Lintadditions.
Thank you,
Bryan Baldus [EMAIL PROTECTED] [EMAIL PROTECTED] http://home.inwave.com/eija