Attention is currently required from: flichtenheld, plaisthos, ralf_lici.

cron2 has posted comments on this change. ( 
http://gerrit.openvpn.net/c/openvpn/+/1022?usp=email )

Change subject: Implement ovpn version detection
......................................................................


Patch Set 1: Code-Review-1

(1 comment)

File src/openvpn/dco_linux.c:

http://gerrit.openvpn.net/c/openvpn/+/1022/comment/9828d2a3_64a0b942 :
PS1, Line 1151:     char *str = BSTR(&buf);
this looks more fumbly than needed - why deal with a `buffer` here if all you 
want is a `*str`?  I'd change this to

```
char * str = gc_malloc(PATH_MAX, false, gc);

...fgets(str, PATH_MAX, fp)...
```

(PATH_MAX is just conveniently lying around and of about the right size, to 
avoid having magic numbers here)



--
To view, visit http://gerrit.openvpn.net/c/openvpn/+/1022?usp=email
To unsubscribe, or for help writing mail filters, visit 
http://gerrit.openvpn.net/settings

Gerrit-Project: openvpn
Gerrit-Branch: master
Gerrit-Change-Id: I7fc033a7ffee73045316763356a95d75ef23f5ad
Gerrit-Change-Number: 1022
Gerrit-PatchSet: 1
Gerrit-Owner: ralf_lici <r...@mandelbit.com>
Gerrit-Reviewer: cron2 <g...@greenie.muc.de>
Gerrit-Reviewer: flichtenheld <fr...@lichtenheld.com>
Gerrit-Reviewer: ordex <anto...@mandelbit.com>
Gerrit-Reviewer: plaisthos <arne-open...@rfc2549.org>
Gerrit-CC: openvpn-devel <openvpn-devel@lists.sourceforge.net>
Gerrit-Attention: plaisthos <arne-open...@rfc2549.org>
Gerrit-Attention: flichtenheld <fr...@lichtenheld.com>
Gerrit-Attention: ralf_lici <r...@mandelbit.com>
Gerrit-Comment-Date: Thu, 15 May 2025 06:20:42 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
_______________________________________________
Openvpn-devel mailing list
Openvpn-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/openvpn-devel

Reply via email to