Tested on the server testbed, which has all the relevant operations here - UDP/TCP client, UDP/TCP servers, ... - all works fine.
The code change itself touches many places, but is actually quite straightforward here - "c->c2.link_socket->..." gets replaced by "sock->...", with "sock" passed in as "c->c2.link_socket" (as of now). .. making many of these functions easier to read, which is nice ;-) (On the renaming of "struct link_socket *ls" to "... *sock" bit, I should have paid more attention earlier in the review process - this is basically an fairly large and unrelated change which makes the code different to 2.6, for no really good reason - maybe keeping the original patch with "struct link_socket *ls" everywhere else would have been nicer, as it's more than "just a socket" anyway) Your patch has been applied to the master branch. commit 490d1324c87446b48462da18cfde1b755c9883e8 Author: Antonio Quartulli Date: Wed Oct 23 10:34:44 2024 +0200 pass link_socket object to i/o functions Signed-off-by: Antonio Quartulli <a...@unstable.cc> Signed-off-by: Gianmarco De Gregori <gianma...@mandelbit.com> Acked-by: Frank Lichtenheld <fr...@lichtenheld.com> Message-Id: <20241023083444.27951-1-g...@greenie.muc.de> URL: https://www.mail-archive.com/openvpn-devel@lists.sourceforge.net/msg29603.html Signed-off-by: Gert Doering <g...@greenie.muc.de> -- kind regards, Gert Doering _______________________________________________ Openvpn-devel mailing list Openvpn-devel@lists.sourceforge.net https://lists.sourceforge.net/lists/listinfo/openvpn-devel