Hi,

I think the code is fine, but I have some nags about the function names:

On Sat, Apr 20, 2013 at 04:22:46PM +0200, Arne Schwabe wrote:
> +#ifdef TARGET_ANDROID
> +static ssize_t write_fd (int fd, void *ptr, size_t nbytes, int flags, int 
> sendfd)
...
> +static ssize_t read_fd(int fd, void *ptr, size_t nbytes, int flags, int 
> *recvfd)

To make it somewhat easier to understand what these do (in the context
of the caller), what do you think about renaming them to

   man_send_with_fd()

and

   man_recv_with_fd()

?

(man_ being the general prefix for "management specific functions", and
send()/recv() being the normal function calls "without fd passing")

gert

-- 
USENET is *not* the non-clickable part of WWW!
                                                           //www.muc.de/~gert/
Gert Doering - Munich, Germany                             g...@greenie.muc.de
fax: +49-89-35655025                        g...@net.informatik.tu-muenchen.de

Attachment: pgpjwvZ0oSlkD.pgp
Description: PGP signature

Reply via email to