-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://codereview.secondlife.com/r/222/#review504
-----------------------------------------------------------


Looking into 247b4c659e7f, I have several remarks:
- main_thread_id : is a global and is not following proper naming convention 
for global
- main_thread_id should really be a static member of the LLViewerTextureList 
class. That's what static class members are for.
- it seems to me that the only objective of LLViewerTextureList is ensure that 
the LLViewerTextureList::addImageToList() is only called from the main thread, 
or rather, from the same thread that the global LLViewerTextureList was created 
in, and crash otherwise (through a call to llassert_always()). I have to say 
I'm not that keen on having thread numbers evaluated and sent around but, OK. 
Is that all you intent to do with that?

Also, please provide a comprehensive RB diff for this. It's easy to create in a 
couple of hg calls (pull, update, merge, diff, rollback and update again). It 
takes much less time than leaving us hunting diff in the changeset history...

- Merov


On March 22, 2011, 3:58 p.m., Xiaohong Bao wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://codereview.secondlife.com/r/222/
> -----------------------------------------------------------
> 
> (Updated March 22, 2011, 3:58 p.m.)
> 
> 
> Review request for Viewer.
> 
> 
> Summary
> -------
> 
> additional fix for STORM-973: [crashhunters] crash at 
> LLViewerTextureList::removeImageFromList(LLViewerFetchedTexture *)
> 
> This fix 
> https://bitbucket.org/BaoLinden/viewer-development-storm-973/changeset/a4a06cbeb360
>  has to be merged together with 
> https://bitbucket.org/BaoLinden/viewer-development-storm-973/changeset/247b4c659e7f
> 
> 
> This addresses bug STORM-973.
>     http://jira.secondlife.com/browse/STORM-973
> 
> 
> Diffs
> -----
> 
> 
> Diff: http://codereview.secondlife.com/r/222/diff
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Xiaohong
> 
>

_______________________________________________
Policies and (un)subscribe information available here:
http://wiki.secondlife.com/wiki/OpenSource-Dev
Please read the policies before posting to keep unmoderated posting privileges

Reply via email to