----------------------------------------------------------- This is an automatically generated e-mail. To reply, visit: http://codereview.secondlife.com/r/2/#review4 -----------------------------------------------------------
Based on the logic of the removed break, line 1192 of the fixed file: idleTimer.getElapsedTimeF64() >= max_idle_time should be idleTimer.getElapsedTimeF64() < max_idle_time The variable "S32 pending;" is redeclared on line 1613 of the fixed file. The previous edition didn't have this issue due to scoping. Looks like the break on 4224 can't be easily removed: it's a tail test in a loop that seems to be required to be a head-test loop. Maybe the logic and purpose can be reanalyzed, but then this would be more than a refactor. - Cron On 2010-12-01 19:57:24, Oz Linden wrote: > > ----------------------------------------------------------- > This is an automatically generated e-mail. To reply, visit: > http://codereview.secondlife.com/r/2/ > ----------------------------------------------------------- > > (Updated 2010-12-01 19:57:24) > > > Review request for Viewer. > > > Summary > ------- > > This review is mostly a first test of reviewboard. > > I do have an esthetic dislike for the 'break' statement anywhere but as the > end of a case, so I chose to change some instances of break usage that were > not justified by any extreme need. > > > This addresses bug storm-606. > http://jira.secondlife.com/browse/storm-606 > > > Diffs > ----- > > indra/newview/llappviewer.cpp bf98b026bcb1 > > Diff: http://codereview.secondlife.com/r/2/diff > > > Testing > ------- > > None at all... have not even compiled it yet. > > > Thanks, > > Oz > >
_______________________________________________ Policies and (un)subscribe information available here: http://wiki.secondlife.com/wiki/OpenSource-Dev Please read the policies before posting to keep unmoderated posting privileges