On Sunday 31 October 2010 10:49:54 David Brownell wrote: > > #define swjdp_memoryap 0 > > #define swjdp_debugap 1 > > For Cortex-A8 it's likely not SWJ-DP but > instead JTAG-DP ... regardless it's best > not to try exposing irrelevant details > like that in naming conventions here... > > > +static const char *variant = NULL; > > "variant" is never changed but ... > > > ... > > + > > uint32_t *dbgbase, uint32_t *apid) > > +{ > > + /* Various CPU-specific quirks */ > > + > > + /* iMX51 misreports ROM Table address > > ... and surely that can be detected, and then > handled in a better way. > > > */ > > + if ((variant != NULL) && > > (strcmp(variant, "imx51") == 0)) > > ... here we assume ight might be ...
What I'd be more interested is 1) Is this approach to detection correct 2) Is the placement of the fixup function in adiv5_dap structure correct 3) Placing the "variant" into adiv5_dap would fix the above, but I don't like the idea ... so where to place it so it can be used from within the fixup function? Cheers _______________________________________________ Openocd-development mailing list Openocd-development@lists.berlios.de https://lists.berlios.de/mailman/listinfo/openocd-development