On Saturday 12 December 2009, Dean Glazeski wrote: > > > > Also, can you restructure it so that you don't just add a bit > > "if (there's a custom erase_page) { ... }"? That's the sort > > of thing which is easier to just require. > > > > So, does this mean we restructure the entire NAND core to get rid of if > (nand->function) {nand->function()} blocks for just about every read and > write command? Look at nand_read_page and nand_write_page. They have that > sort of logic.
Those are the worst offenders. Yes, I think that sort of cleanup would be a good thing. _______________________________________________ Openocd-development mailing list Openocd-development@lists.berlios.de https://lists.berlios.de/mailman/listinfo/openocd-development