On Thu, 24 Apr 2025 17:04:42 GMT, Martin Fox <m...@openjdk.org> wrote:
> I did a rough pass on macOS and Windows. There's some failures in the > StageLocation and StageAttributes tests that I haven't had time to look into. > > You might want to consider adding a few delay constants and using them > instead of the 500's you've scattered through these tests. There's the delay > needed for big state changes (like entering and exiting fullscreen) and that > needs to be 500 or more. Then there's the delay for waiting for a layout > pulse and I'm assuming that could be significantly shorter. I can do that. Do you suggest a per test class constants, or maybe in Util? > > There seem to be places where you compare an attribute like Stage.getWidth() > against a constant using strict equality and other places where you provide a > tolerance delta. I suspect you want a delta in more locations but someone > else will have to chime in on that. I think this mostly affects Windows > machines using fractional scaling. > I think I did use a tolerance delta for decorated windows. Since I'm not very familiar with fractional scaling, I'm wondering how much tolerance is generally recommended in these cases? > There was a discussion a while back about naming conventions and I think the > consensus was that new tests should not have "test" in the name (so > testMinSize should be minSize or minStageSize). But I might be wrong on that > and in the end it's a matter of style. I did search the mailing list and did not find the consensus (I believe there is one, I just didn't find it :) ------------- PR Comment: https://git.openjdk.org/jfx/pull/1789#issuecomment-2829033954