On Tue, 3 Sep 2024 17:58:40 GMT, Nir Lisker <nlis...@openjdk.org> wrote:
> Isn't `CancellationToken` a simplified `Subscription`? Won't the additional > methods on the latter be of use here? Yes it is. I thought about using `Subscription`, but the method name `unsubscribe()` doesn't seem to match what is happening. Maybe we can add something like `Cancellable` in the future, if at any point in time we require similar semantics. ------------- PR Comment: https://git.openjdk.org/jfx/pull/1522#issuecomment-2327121283