On Thu, 16 May 2024 14:54:47 GMT, Andy Goryachev <ango...@openjdk.org> wrote:
>> modules/javafx.graphics/src/main/java/javafx/scene/layout/Region.java line >> 1212: >> >>> 1210: * <p> >>> 1211: * Defaults to the <code>USE_COMPUTED_SIZE</code> flag, which >>> means that >>> 1212: * {@link #prefHeight(forWidth)} will return the region's >>> internally >> >> 1. In this file, the documentation for other properties like minWidth, >> minHeight use `<code>` >> For similarity I think we should keep `<code>` or change others as well >> to `link`. >> >> 2. There are similar correction needed at four other places in this file. As >> we are touching this file, I think these can be corrected too. If modified >> then the issue summary would need a modification too. >> 1252: * <code>getMaxWidth(forHeight)</code> will return the region's >> internally >> 1256: * <code>getMaxWidth(forHeight)</code> to return the region's >> preferred width, >> 1281: * <code>getMaxHeight(forWidth)</code> will return the region's >> internally >> 1285: * <code>getMaxHeight(forWidth)</code> to return the region's >> preferred height >> >> 3. Similar mistakes are observed in the PopupControl.java file too. I leave >> it to you to correct those here or handle separately > > thank you for pointing this out, I am going to revert back to `<code>` and > update `PopupControl`. Looks good, I recommend to update the summary, current summary is quite specific to Region / prefWidth/Height. A suggestion-> javadoc: incorrect method references in Region and PopupControl ------------- PR Review Comment: https://git.openjdk.org/jfx/pull/1456#discussion_r1603683364