On Mon, Jul 18, 2016 at 12:57:55PM -0500, George McCollister wrote: > If INITRAMFS_IMAGE is set, build an additional fitImage containing the > initramfs. Copy the additional fitImage and the source (*.its) file, used > to create it to DEPLOYDIR. The fitImage containing the initramfs must be > built before do_deploy and after do_install to avoid circular dependencies. > > UBOOT_RD_LOADADDRESS - Specifies the load address used by u-boot for the > initramfs. > UBOOT_RD_ENTRYPOINT - Specifies the entry point used by u-boot for the > initramfs. > > Signed-off-by: George McCollister <george.mccollis...@gmail.com> > --- > meta/classes/kernel-fitimage.bbclass | 282 > +++++++++++++++++++++++------------ > 1 file changed, 187 insertions(+), 95 deletions(-) > > diff --git a/meta/classes/kernel-fitimage.bbclass > b/meta/classes/kernel-fitimage.bbclass > index 9a3caf5..ede69e7 100644 > --- a/meta/classes/kernel-fitimage.bbclass > +++ b/meta/classes/kernel-fitimage.bbclass > @@ -16,7 +16,7 @@ python __anonymous () { >
<snip> > + # > + # Step 3: Prepare a ramdisk section. > + # > + if [ "x${ramdiskcount}" = "x1" ] ; then > + copy_initramfs > + fitimage_emit_section_ramdisk ${1} "${ramdiskcount}" > ${B}/usr/${INITRAMFS_IMAGE}-${MACHINE}.cpio May I suggest dropping ${B} here to get the ramdisk path shorter and easier to read? It's relative to ${B} anyway - same as all the DTBs... + fitimage_emit_section_ramdisk ${1} "${ramdiskcount}" usr/${INITRAMFS_IMAGE}-${MACHINE}.cpio > + fi > <snip> -- Denys -- _______________________________________________ Openembedded-core mailing list Openembedded-core@lists.openembedded.org http://lists.openembedded.org/mailman/listinfo/openembedded-core