On 23 December 2015 at 23:51, Haris Okanovic <haris.okano...@ni.com> wrote:

> +CONFFILES_${PN} +=
> "${@['','${sysconfdir}/timezone'][d.getVar('INSTALL_TIMEZONE_FILE', True)
> == '1']}"
>

This idiom (indexing an array by a coerced boolean) is pretty difficult to
read and bitbake has a helper function to turn a string into a bool, so I
find something like this a lot easier to read:

${@"${sysconfdir}/timezone" if
bb.utils.to_boolean(d.getVar("INSTALL_TIMEZONE_FILE", True)) else ""}

(untested!)

Ross
-- 
_______________________________________________
Openembedded-core mailing list
Openembedded-core@lists.openembedded.org
http://lists.openembedded.org/mailman/listinfo/openembedded-core

Reply via email to