On 3 March 2015 at 16:46, Naresh Bhat <naresh.b...@linaro.org> wrote:
> Add to support to install grubaa64.efi binary for aarch64
>
> Signed-off-by: Naresh Bhat <naresh.b...@linaro.org>
> Signed-off-by: Matt Fleming <matt.flem...@intel.com>
> ---
>  meta/classes/grub-efi.bbclass |    3 +++
>  1 file changed, 3 insertions(+)
>
> diff --git a/meta/classes/grub-efi.bbclass b/meta/classes/grub-efi.bbclass
> index 47bd35e..455dc8d 100644
> --- a/meta/classes/grub-efi.bbclass
> +++ b/meta/classes/grub-efi.bbclass
> @@ -37,6 +37,9 @@ efi_populate() {
>         if [ "${TARGET_ARCH}" = "x86_64" ]; then
>                 GRUB_IMAGE="bootx64.efi"
>         fi
> +       if [ "${TARGET_ARCH}" = "aarch64" ]; then
> +                GRUB_IMAGE="grubaa64.efi"
> +        fi

Assuming you're adding at least the second call to test(1) in a row
I'd have switched the whole thing to a case statement.
This would be easier to read, fewer lines and on some shells fewer
forks of test(1), fwiw.

thanks,
-- 
_______________________________________________
Openembedded-core mailing list
Openembedded-core@lists.openembedded.org
http://lists.openembedded.org/mailman/listinfo/openembedded-core

Reply via email to