On Fri, May 20, 2011 at 11:29 AM, Richard Purdie <richard.pur...@linuxfoundation.org> wrote: > Yes please :) > >> >> --- a/meta/classes/image.bbclass >> >> +++ b/meta/classes/image.bbclass >> >> @@ -11,8 +11,45 @@ INHIBIT_DEFAULT_DEPS = "1" >> >> >> >> # "export IMAGE_BASENAME" not supported at this time >> >> IMAGE_BASENAME[export] = "1" >> >> -export PACKAGE_INSTALL ?= "${IMAGE_INSTALL}" >> >> -PACKAGE_INSTALL_ATTEMPTONLY ?= "" >> >> + >> >> +PACKAGE_INSTALL = "${@' >> >> '.join(oe.packagegroup.required_packages('${IMAGE_FEATURES}'.split(), >> >> d))}" >> >> +PACKAGE_INSTALL_ATTEMPTONLY = "${@' >> >> '.join(oe.packagegroup.optional_packages('${IMAGE_FEATURES}'.split(), >> >> d))}" >> >> +RDEPENDS += "${@' >> >> '.join(oe.packagegroup.active_packages('${IMAGE_FEATURES}'.split(), d))}" >> > >> > I also noticed this patch changes things so PACKAGE_INSTALL_ATTEMPTONLY >> > is used for the dev/doc/dbg packages. I'm not sure its a major issue but >> > it is a change in behaviour and I'd have expected it in the commit >> > message. >> >> Ah, that's my mistake then, I didn't realize the behavior was >> different in the current implementation. I just figured some packages >> might not have dev/doc/dbg, so it should be nonfatal to miss them. We >> may also need to make sure rpm/deb both handle attemptonly properly, >> as upstream's did not. I'll add this to the commit message, unless you >> think they shouldn't be optional? I'm inclined to prefer it this way, >> as, iirc, the depchain stuff uses recommends rather than depends. >> (though i may be remembering wrong?) > > I just checked and all the rootfs package backends have code which looks > like it makes that work. I'm fine with the behaviour change as long as > we document it. > > FWIW, I merged the other patches in the series since they were not > directly related.
Thanks, I'll resend this commit shortly. Aside: can anyone think of a better name than PACKAGE_GROUP for defining named groups of packages? I rather dislike it, but can't think of anything better. PACKAGES is clearly already used, and isn't sufficiently explicit. PACKAGESET or something could work, but I don't know that it's an improvement.. maybe this is best, but I thought I'd ask. I'm terrible at naming just about everything, projects included (*cough* OE *cough*) :) -- Christopher Larson clarson at kergoth dot com Founder - BitBake, OpenEmbedded, OpenZaurus Maintainer - Tslib Senior Software Engineer, Mentor Graphics _______________________________________________ Openembedded-core mailing list Openembedded-core@lists.openembedded.org http://lists.linuxtogo.org/cgi-bin/mailman/listinfo/openembedded-core