aacid added inline comments. INLINE COMMENTS
> part.cpp:377 > + // also connect to the find argument from terminal, searching only after > loading file. > + connect(this, SIGNAL(completed()), this, SLOT(findTextOnStartUp())); > connect(this, &KParts::ReadOnlyPart::canceled, this, > &Part::loadCancelled); You don't need this, just do it after open. > part.cpp:1716 > { > m_viewportDirty.pageNumber = -1; > That is, move the code from findTextOnStartUp here, also clean up the textToFind variable. > part.h:413 > + // String to search in document startup > + QString textToFind; > + Needs m_ prefix. And also a better name, something m_textToFindOnOpen. REPOSITORY R223 Okular REVISION DETAIL https://phabricator.kde.org/D18144 To: joaonetto, #okular Cc: ngraham, aacid, yurchor, okular-devel, darcyshen