-Wflex-array-member-not-at-end was introduced in GCC-14, and we are
getting ready to enable it, globally.

Use the `DEFINE_RAW_FLEX()` helper for an on-stack definition of
a flexible structure where the size of the flexible-array member
is known at compile-time, and refactor the rest of the code,
accordingly.

So, with these changes, fix the following warning:

drivers/gpu/drm/nouveau/nvif/outp.c:199:45: warning: structure containing a 
flexible array member is not at the end of another structure 
[-Wflex-array-member-not-at-end]

Signed-off-by: Gustavo A. R. Silva <gustavo...@kernel.org>
---
Changes in v2:
 - Avoid using magic number in if statement. (Danilo)
 - Use sizeof() instead of __struct_size().

v1:
 - Link: https://lore.kernel.org/linux-hardening/Z-a2DAQmcsHHlyci@kspp/

 drivers/gpu/drm/nouveau/nvif/outp.c | 15 ++++++---------
 1 file changed, 6 insertions(+), 9 deletions(-)

diff --git a/drivers/gpu/drm/nouveau/nvif/outp.c 
b/drivers/gpu/drm/nouveau/nvif/outp.c
index 6daeb7f0b09b..1ea20b2bdd29 100644
--- a/drivers/gpu/drm/nouveau/nvif/outp.c
+++ b/drivers/gpu/drm/nouveau/nvif/outp.c
@@ -195,20 +195,17 @@ nvif_outp_dp_aux_pwr(struct nvif_outp *outp, bool enable)
 int
 nvif_outp_hda_eld(struct nvif_outp *outp, int head, void *data, u32 size)
 {
-       struct {
-               struct nvif_outp_hda_eld_v0 mthd;
-               u8 data[128];
-       } args;
+       DEFINE_RAW_FLEX(struct nvif_outp_hda_eld_v0, mthd, data, 128);
        int ret;
 
-       if (WARN_ON(size > ARRAY_SIZE(args.data)))
+       if (WARN_ON(size > (__struct_size(mthd) - sizeof(*mthd))))
                return -EINVAL;
 
-       args.mthd.version = 0;
-       args.mthd.head = head;
+       mthd->version = 0;
+       mthd->head = head;
 
-       memcpy(args.data, data, size);
-       ret = nvif_mthd(&outp->object, NVIF_OUTP_V0_HDA_ELD, &args, 
sizeof(args.mthd) + size);
+       memcpy(mthd->data, data, size);
+       ret = nvif_mthd(&outp->object, NVIF_OUTP_V0_HDA_ELD, mthd, 
sizeof(*mthd) + size);
        NVIF_ERRON(ret, &outp->object, "[HDA_ELD head:%d size:%d]", head, size);
        return ret;
 }
-- 
2.43.0


Reply via email to