On Tue, 13 Oct 2015 22:58:31 -0700, Ronen Arad wrote: > --- a/include/net/rtnetlink.h > +++ b/include/net/rtnetlink.h > @@ -130,6 +130,8 @@ struct rtnl_af_ops { > const struct nlattr *attr); > int (*set_link_af)(struct net_device *dev, > const struct nlattr *attr); > + size_t (*get_link_af_size_filtered)(const struct > net_device *dev, > + u32 > ext_filter_mask); > };
There's not much point in having two callbacks doing essentially the same. Why you just don't add the new parameter to the existing get_link_af_size? Looking at what the patch 3 does, the current implementations of the callback can just ignore the new parameter and bridge can remove the current br_get_link_af and rename br_get_link_af_size_filtered to br_get_link_af. Jiri -- Jiri Benc -- To unsubscribe from this list: send the line "unsubscribe netdev" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html