On Tue, Sep 29, 2015 at 3:39 PM, Joe Stringer <joestrin...@nicira.com> wrote: > Previously, the CT_ATTR_FLAGS attribute, when nested under the > OVS_ACTION_ATTR_CT, encoded a 32-bit bitmask of flags that modify the > semantics of the ct action. It's more extensible to just represent each > flag as a nested attribute, and this requires no additional error > checking to reject flags that aren't currently supported. > > Suggested-by: Ben Pfaff <b...@nicira.com> > Signed-off-by: Joe Stringer <joestrin...@nicira.com> > --- ... ...
> diff --git a/net/openvswitch/conntrack.c b/net/openvswitch/conntrack.c > index 167cf43..effa78c 100644 > --- a/net/openvswitch/conntrack.c > +++ b/net/openvswitch/conntrack.c > @@ -42,12 +42,18 @@ struct md_label { > struct ovs_key_ct_label mask; > }; > > +/* Flags for performing connection tracking. > + * > + * CT_F_COMMIT: Commits the flow to the conntrack table. > + */ > +#define CT_F_COMMIT BIT(0) > + > /* Conntrack action context for execution. */ > struct ovs_conntrack_info { > struct nf_conntrack_helper *helper; > struct nf_conntrack_zone zone; > struct nf_conn *ct; > - u32 flags; > + u8 flags; /* bitmask of CT_F_*. */ I think bit field has better readability in such use case. Otherwise looks good. -- To unsubscribe from this list: send the line "unsubscribe netdev" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html