From: Jiri Pirko <j...@mellanox.com>

Jiri Pirko (10):
  switchdev: rename "trans" to "trans_ph".
  switchdev: introduce transaction item queue for attr_set and obj_add
  switchdev: move transaction phase enum under transaction structure
  switchdev: add switchdev_trans_ph_prepare/commit helpers
  rocker: push struct switchdev_trans down through rocker code
  rocker: use switchdev transaction queue for allocated memory
  switchdev: remove "NONE" transaction phase
  switchdev: remove "ABORT" transaction phase
  dsa: use prepare/commit switchdev transaction helpers
  switchdev: reduce transaction phase enum down to a boolean

 Documentation/networking/switchdev.txt |  19 ++
 drivers/net/ethernet/rocker/rocker.c   | 308 ++++++++++++++-------------------
 include/net/switchdev.h                |  40 +++--
 net/dsa/slave.c                        |  31 ++--
 net/switchdev/switchdev.c              | 125 ++++++++++---
 5 files changed, 296 insertions(+), 227 deletions(-)

-- 
1.9.3

--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to