On Tue, Sep 1, 2015 at 6:16 AM, David Miller <da...@davemloft.net> wrote:
> From: Xin Long <lucien....@gmail.com>
> Date: Tue,  1 Sep 2015 01:44:28 +0800
>
>> @@ -524,18 +524,16 @@ static inline int sctp_assoc_hashfn(struct net *net, 
>> __u16 lport, __u16 rport)
>>  {
>>       int h = (lport << 16) + rport + net_hash_mix(net);
>>       h ^= h>>8;
>> -     return h & (sctp_assoc_hashsize - 1);
>> +     return h & (256 - 1);
>
> It is not acceptable to use a magic constant for the hash table size.
> You need to define this using a macro and use it consistently.
>
> Furthermore, you should be looking into dynamically sized
> hash tables because not everyone will need this many entries.

okay, I will correct it, thanks
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to