On Fri, 2015-07-17 at 15:44 +0200, Hagen Paul Pfeifer wrote: > > On July 16, 2015 at 9:23 PM Joe Perches <j...@perches.com> wrote: > > > > It might be useful to have these performance impacting > > changes guarded by something like CONFIG_CC_OPTIMIZE_FOR_SIZE > > with another static __always_inline __<func> and a function & > > EXPORT_SYMBOL or just a static inline so that where code size > > is critical it's uninlined. > > But keep in mind that jhash, jhash2 and __jhash_nwords are *not* > one-instruction long functions. We duplicate code over and over resulting > probably in more cache misses. __always_inline__ is probably too strict > and a vanilla inline is already for 99% of all distribution builds a > __always_inline__, see ARCH_SUPPORTS_OPTIMIZED_INLINING and > CONFIG_CC_OPTIMIZE_FOR_SIZE.
Hello. Perhaps I wasn't clear/explicit enough. I tried to suggest using a single __always_inline like this: Two #ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE (or some other CONFIG_FOO) functions, one in a .h for the existing behavior and another in a .c for more code space compact uses. jhash.h static __always_inline u32 __jhash(const void *key, u32 length, u32 initval) { [current jhash implementation...] } #ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE u32 jhash(const void *key, u32 length, u32 initval); #else static inline u32 jhash(const void *key, u32 length, u32 initval) { return __jhash(key, length, initval); } #endif jhash.c: #ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE u32 jhash(const void *key, u32 length, u32 initval) { return __jhash(key, length, initval); } EXPORT_SYMBOL(jhash) #endif etc... Perhaps the additional code complexity is not worth it. -- To unsubscribe from this list: send the line "unsubscribe netdev" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html