On Wed, Jun 10, 2015 at 7:23 PM, Andy Gospodarek <go...@cumulusnetworks.com> wrote: > On Wed, Jun 10, 2015 at 07:18:59PM -0700, Scott Feldman wrote: >> On Wed, Jun 10, 2015 at 7:12 PM, Scott Feldman <sfel...@gmail.com> wrote: >> > On Tue, Jun 9, 2015 at 11:47 PM, Andy Gospodarek >> > <go...@cumulusnetworks.com> wrote: >> > >> >> /* /proc/sys/net/ipv4/netfilter */ >> >> diff --git a/kernel/sysctl_binary.c b/kernel/sysctl_binary.c >> >> index 7e7746a..c9d0a0e 100644 >> >> --- a/kernel/sysctl_binary.c >> >> +++ b/kernel/sysctl_binary.c >> >> @@ -253,6 +253,7 @@ static const struct bin_table >> >> bin_net_ipv4_conf_vars_table[] = { >> >> { CTL_INT, NET_IPV4_CONF_NOPOLICY, >> >> "disable_policy" }, >> >> { CTL_INT, NET_IPV4_CONF_FORCE_IGMP_VERSION, >> >> "force_igmp_version" }, >> >> { CTL_INT, NET_IPV4_CONF_PROMOTE_SECONDARIES, >> >> "promote_secondaries" }, >> >> + { CTL_INT, NET_IPV4_CONF_IGNORE_ROUTES_WITH_LINKDOWN, >> >> "ignore_routes_with_linkdown" }, >> > >> > Would "route_ignore_linkdown_nexthops" be a more accurate name? The >> > patch marks link-downed nexthops to be ignored, not the route, >> > correct? >> > >> > s/NET_IPV4_CONF_IGNORE_ROUTES_WITH_LINKDOWN/NET_IPV4_CONF_ROUTE_IGNORE_LINKDOWN_NEXTHOPS >> >> Something like that. Not sure I like my suggestion. If dev is >> nexthop dev in route, and dev is link down, exclude nexthop in route >> lookup. > > I actually played around with a bunch of different names and this was as > short as I could get it while still conveying the point. I'm getting > ready to submit v3, so speak now if you really do hate the name proposed > in v2. > >> route_exclude_if_linkdown_nexthop_dev? > > Not bad, but you see what I mean about it being a mouthful. :)
I think I'd rather see clarity over brevity in this case. The current name makes the attr sound like a route property but it's really a prop of the dev when the dev is a nexthop in a route and the dev link is down. -- To unsubscribe from this list: send the line "unsubscribe netdev" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html