On Wed, Mar 10, 2021 at 01:14:19PM -0800, Ilya Lipnitskiy wrote: > When disabling PLL, there is no need to call core_write_mmd_indirect > directly, use the core_write wrapper instead like the rest of the code > in the function does. This change helps with consistency and > readability. > > Signed-off-by: Ilya Lipnitskiy <ilya.lipnits...@gmail.com> > --- > drivers/net/dsa/mt7530.c | 5 +---- > 1 file changed, 1 insertion(+), 4 deletions(-) > > diff --git a/drivers/net/dsa/mt7530.c b/drivers/net/dsa/mt7530.c > index e785f80f966b..b106ea816778 100644 > --- a/drivers/net/dsa/mt7530.c > +++ b/drivers/net/dsa/mt7530.c > @@ -445,10 +445,7 @@ mt7530_pad_clk_setup(struct dsa_switch *ds, > phy_interface_t interface) > * provide our own core_write_mmd_indirect to complete this > * function. > */ > - core_write_mmd_indirect(priv, > - CORE_GSWPLL_GRP1, > - MDIO_MMD_VEND2, > - 0); > + core_write(priv, CORE_GSWPLL_GRP1, 0);
/* Disable PLL, since phy_device has not yet been created * provided for phy_[read,write]_mmd_indirect is called, we * provide our own core_write_mmd_indirect to complete this * function. */ core_write_mmd_indirect(priv, CORE_GSWPLL_GRP1, MDIO_MMD_VEND2, 0); What about the comment? Seems odd to reference core_write_mmd_indirect() when it is not actually called here after your change. Andrew