From: Arthur Kiyanovski <akiy...@amazon.com> V4 Changes: ----------- Added an explanation to the decision of using netdev_* prints in functions that are also called before netdev is registered.
V3 Changes: ----------- 1. Removed RFC, the commits that this patchset relies on where merged from net already so no more conflicts are expected. 2. Fixed checkpatch errors. V2 Changes: --------------- 1. Changed this to RFC, since we are waiting for the recently merged net patches to be merged so there will be no merge conflicts. But still would like to get review comments beforehand. 2. Removed the word "atomic" from the name of ena_increase_stat_atomic(), as it is indeed not atomic. V1 Cover Letter: ---------------- Hi all, ENA is adding XDP Redirect support for its driver and some other small tweaks. This series adds the following: - Make log messages in the driver have a uniform format using netdev_* function - Improve code readability and add explicit masking - Add support for XDP Redirect Arthur Kiyanovski (9): net: ena: use constant value for net_device allocation net: ena: add device distinct log prefix to files net: ena: add explicit casting to variables net: ena: fix coding style nits net: ena: aggregate stats increase into a function net: ena: use xdp_frame in XDP TX flow net: ena: introduce XDP redirect implementation net: ena: use xdp_return_frame() to free xdp frames net: ena: introduce ndo_xdp_xmit() function for XDP_REDIRECT drivers/net/ethernet/amazon/ena/ena_com.c | 394 ++++++++++------- drivers/net/ethernet/amazon/ena/ena_com.h | 21 + drivers/net/ethernet/amazon/ena/ena_eth_com.c | 71 ++-- drivers/net/ethernet/amazon/ena/ena_eth_com.h | 23 +- drivers/net/ethernet/amazon/ena/ena_ethtool.c | 3 +- drivers/net/ethernet/amazon/ena/ena_netdev.c | 395 ++++++++++-------- drivers/net/ethernet/amazon/ena/ena_netdev.h | 12 +- 7 files changed, 544 insertions(+), 375 deletions(-) -- 2.23.3