On Thu, 29 Oct 2020 12:41:41 +0000 Russell King - ARM Linux admin <li...@armlinux.org.uk> wrote:
> I think this is probably a better way forward, and I suspect we're going > to see more of this stuff. I wonder, however, whether the configuration > should be done here too (selecting page 1). Also, shouldn't we ensure > that we are on page 1 before attempting any access? Very well. > It would be good to pass this through checkpatch - I notice some lines > seem to be over the 80 character limit now. Checkpatch does not complain at over 80 characters anymore, but over 100. But I will rewrite it. > "iterations" /o\ thx > > + val = res[4]; > > + val <<= 8; > > + val |= res[5]; > > Was there something wrong with: > > val = res[4] << 8 | res[5]; > > here? For some reason I preferred to use the 3-liner, but I shall rewrite it. > > > +struct mii_bus *mdio_i2c_alloc(struct device *parent, struct i2c_adapter > > *i2c, > > + enum mdio_i2c_type type) > > Maybe call this "protocol" rather than "type" ? Very well, thx