Oh, and ... > > +/** > > + * netlink_policy_dump_add_policy - add a policy to the dump > > + * @pstate: state to add to, may be reallocated, must be %NULL the first > > time > > + * @policy: the new policy to add to the dump > > + * @maxtype: the new policy's max attr type > > + * > > + * Returns: 0 on success, a negative error code otherwise. > > + * > > + * Call this to allocate a policy dump state, and to add policies to it. > > This > > + * should be called from the dump start() callback. > > + * > > + * Note: on failures, any previously allocated state is freed. > > + */ > > +int netlink_policy_dump_add_policy(struct netlink_policy_dump_state > > **pstate, > > + const struct nla_policy *policy, > > + unsigned int maxtype); > > Personal preference perhaps, but I prefer kdoc with the definition.
I realized recently that this is actually better, because then "make W=1" will in fact check the kernel-doc for consistency ... but it doesn't do it in header files. Just have to get into the habit now ... johannes