Refactor the .flow_dissect procedure to call the common helper instead of open-coding the header displacement.
Cc: Andrew Lunn <and...@lunn.ch> Signed-off-by: Vladimir Oltean <vladimir.olt...@nxp.com> --- net/dsa/tag_dsa.c | 9 +-------- 1 file changed, 1 insertion(+), 8 deletions(-) diff --git a/net/dsa/tag_dsa.c b/net/dsa/tag_dsa.c index ef15aee58dfc..413086dcddb4 100644 --- a/net/dsa/tag_dsa.c +++ b/net/dsa/tag_dsa.c @@ -142,19 +142,12 @@ static struct sk_buff *dsa_rcv(struct sk_buff *skb, struct net_device *dev, return skb; } -static void dsa_tag_flow_dissect(const struct sk_buff *skb, __be16 *proto, - int *offset) -{ - *offset = 4; - *proto = ((__be16 *)skb->data)[1]; -} - static const struct dsa_device_ops dsa_netdev_ops = { .name = "dsa", .proto = DSA_TAG_PROTO_DSA, .xmit = dsa_xmit, .rcv = dsa_rcv, - .flow_dissect = dsa_tag_flow_dissect, + .flow_dissect = dsa_tag_generic_flow_dissect, .overhead = DSA_HLEN, }; -- 2.25.1