Hi, in order to reduce code duplication in the ptp code of DSA, Ethernet and Phy drivers, move the header parsing function to ptp_classify. This way all drivers can share the same implementation. Implemented as discussed [1] [2] [3].
This is version two and contains more driver conversions. Richard, can you test with your hardware? I'll do the same e.g. on the bbb. Version 1 can be found here: * https://lkml.kernel.org/netdev/20200723074946.14253-1-k...@linutronix.de/ Thanks, Kurt Changes since v1: * Fix Kconfig (Richard Cochran) * Include more drivers (Richard Cochran) [1] - https://lkml.kernel.org/netdev/20200713140112.GB27934@hoboy/ [2] - https://lkml.kernel.org/netdev/20200720142146.GB16001@hoboy/ [3] - https://lkml.kernel.org/netdev/20200723074946.14253-1-k...@linutronix.de/ Kurt Kanzenbach (9): ptp: Add generic ptp v2 header parsing function ptp: Add generic ptp message type function net: dsa: mv88e6xxx: Use generic helper function mlxsw: spectrum_ptp: Use generic helper function ethernet: ti: am65-cpts: Use generic helper function ethernet: ti: cpts: Use generic helper function net: phy: dp83640: Use generic helper function ptp: ptp_ines: Use generic helper function ptp: Remove unused macro drivers/net/dsa/mv88e6xxx/hwtstamp.c | 59 +++---------- .../ethernet/mellanox/mlxsw/spectrum_ptp.c | 32 ++----- drivers/net/ethernet/ti/am65-cpts.c | 37 ++------ drivers/net/ethernet/ti/cpts.c | 37 ++------ drivers/net/phy/dp83640.c | 69 ++++----------- drivers/ptp/ptp_ines.c | 88 ++++++------------- include/linux/ptp_classify.h | 63 ++++++++++++- net/core/ptp_classifier.c | 30 +++++++ 8 files changed, 171 insertions(+), 244 deletions(-) -- 2.20.1