On 7/4/20 8:28 AM, Kuniyuki Iwashima wrote:
> Commit 0c3d79bce48034018e840468ac5a642894a521a3 ("tcp: reduce SYN-ACK
> retrans for TCP_DEFER_ACCEPT") introduces syn_ack_recalc() which decides
> if a minisock is held and a SYN+ACK is retransmitted or not.
>
> If rskq_defer_accept is not zero in syn_ack_recalc(), max_retries always
> has the same value because max_retries is overwritten by rskq_defer_accept
> in reqsk_timer_handler().
>
> This commit adds two changes:
> - remove max_retries from the arguments of syn_ack_recalc() and use
> rskq_defer_accept instead.
> - rename thresh to max_retries for readability.
>
Honestly this looks unnecessary code churn to me.
This will make future backports more error prone.
Real question is : why do you want this change in the first place ?