Instead of slave_kind, rename variable to sub_kind
to describe the kind of sub-device that is being looked for
when filtering messages.

Signed-off-by: Stephen Hemminger <step...@networkplumber.org>
---
 ip/ip_common.h | 2 +-
 ip/ipaddress.c | 4 ++--
 2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/ip/ip_common.h b/ip/ip_common.h
index d604f7554405..7d0c9f57745a 100644
--- a/ip/ip_common.h
+++ b/ip/ip_common.h
@@ -23,7 +23,7 @@ struct link_filter {
        int group;
        int master;
        char *kind;
-       char *slave_kind;
+       char *sub_kind;
        int target_nsid;
 };
 
diff --git a/ip/ipaddress.c b/ip/ipaddress.c
index f97eaff3dbbf..4cbff38c9834 100644
--- a/ip/ipaddress.c
+++ b/ip/ipaddress.c
@@ -924,7 +924,7 @@ int print_linkinfo(struct nlmsghdr *n, void *arg)
        if (filter.kind && match_link_kind(tb, filter.kind, 0))
                return -1;
 
-       if (filter.slave_kind && match_link_kind(tb, filter.slave_kind, 1))
+       if (filter.sub_kind && match_link_kind(tb, filter.sub_kind, 1))
                return -1;
 
        if (n->nlmsg_type == RTM_DELLINK)
@@ -2012,7 +2012,7 @@ static int ipaddr_list_flush_or_save(int argc, char 
**argv, int action)
                        soff = strlen(*argv) - strlen("_slave");
                        if (!strcmp(*argv + soff, "_slave")) {
                                (*argv)[soff] = '\0';
-                               filter.slave_kind = *argv;
+                               filter.sub_kind = *argv;
                        } else {
                                filter.kind = *argv;
                        }
-- 
2.26.2

Reply via email to