On 28/05/2020 20:49, David Miller wrote: > From: Arnd Bergmann <a...@arndb.de> > Date: Wed, 27 May 2020 15:41:06 +0200 > >> 'nic_data' is no longer used outside of the #ifdef block >> in efx_ef10_set_mac_address: >> >> drivers/net/ethernet/sfc/ef10.c:3231:28: error: unused variable 'nic_data' >> [-Werror,-Wunused-variable] >> struct efx_ef10_nic_data *nic_data = efx->nic_data; >> >> Move the variable into a local scope. >> >> Fixes: dfcabb078847 ("sfc: move vport_id to struct efx_nic") >> Signed-off-by: Arnd Bergmann <a...@arndb.de> > Applid, thanks. Sorry I didn't see the original patch (I think it disappeared into a mail outage). Fix is good, but I think we can improve the code further by moving the declaration down another block, into the 'if (rc == -EPERM)', at which point it is no longer shadowed by the other nic_data declaration in the 'else if (!rc)' block. Alternatively, we could rename the latter to 'pf_nic_data' or something. Any opinions/preferences on which way to go? We could even do both... When I make up my mind I'll spin an incremental patch.
-ed