Few people reported that some laptops are coming with new ACPI ID for the devices should be supported by nxp-nci driver.
This series adds new ID (patch 2), cleans up the driver from legacy platform data and unifies GPIO request for Device Tree and ACPI (patches 3-6), removes dead or unneeded code (patches 7, 9, 11), constifies ID table (patch 8), removes comma in terminator line for better maintenance (patch 10) and rectifies Kconfig entry (patches 12-14). It also contains a fix for NFC subsystem as suggested by Sedat. Series has been tested by Sedat. Changelog v4: - rebased on top of latest linux-next - appended cover letter - elaborated removal of pr_fmt() in the patch 11 (David) Andrey Konovalov (1): NFC: fix attrs checks in netlink interface Andy Shevchenko (11): NFC: nxp-nci: Add NXP1001 to the ACPI ID table NFC: nxp-nci: Get rid of platform data NFC: nxp-nci: Convert to use GPIO descriptor NFC: nxp-nci: Add GPIO ACPI mapping table NFC: nxp-nci: Get rid of code duplication in ->probe() NFC: nxp-nci: Get rid of useless label NFC: nxp-nci: Constify acpi_device_id NFC: nxp-nci: Drop of_match_ptr() use NFC: nxp-nci: Drop comma in terminator lines NFC: nxp-nci: Remove unused macro pr_fmt() NFC: nxp-nci: Remove 'default n' for the core Sedat Dilek (2): NFC: nxp-nci: Clarify on supported chips NFC: nxp-nci: Fix recommendation for NFC_NXP_NCI_I2C Kconfig MAINTAINERS | 1 - drivers/nfc/nxp-nci/Kconfig | 7 +- drivers/nfc/nxp-nci/core.c | 2 - drivers/nfc/nxp-nci/i2c.c | 134 +++++++------------------- drivers/nfc/nxp-nci/nxp-nci.h | 1 - include/linux/platform_data/nxp-nci.h | 19 ---- net/nfc/netlink.c | 6 +- 7 files changed, 41 insertions(+), 129 deletions(-) delete mode 100644 include/linux/platform_data/nxp-nci.h -- 2.20.1