On Mon, 24 Jun 2019 15:55:49 -0600 David Ahern <dsah...@gmail.com> wrote:
> On 6/14/19 7:33 PM, Stefano Brivio wrote: > > diff --git a/ip/iproute.c b/ip/iproute.c > > index 2b3dcc5dbd53..192442b42062 100644 > > --- a/ip/iproute.c > > +++ b/ip/iproute.c > > @@ -1602,6 +1602,16 @@ static int save_route_prep(void) > > return 0; > > } > > > > +static int iproute_flush_flags(struct nlmsghdr *nlh, int reqlen) > > rename that to iproute_flush_filter to be consistent with > iproute_dump_filter. I originally wanted to make it obvious that it's not an actual filter, but: > Actually, why can't the flush code use iproute_dump_filter? ...come on. That would be too simple. No, my original understanding was that strict checking didn't imply filtering. It does, and the current kernel implementation matches, now also for RTM_F_CACHED. So yes, we can use it, and it doesn't cause any unexpected behaviours with older kernels either. Sending v2. Thanks for pointing this out. -- Stefano