On Tue, 12 Dec 2006 12:55:53 -0500, Michael Wu wrote: > - schedule_work(&local->scan_work); > + schedule_work(&local->scan_work.work);
Hm, what is the preferred way here: schedule_work(some_delayed_work.work) or schedule_delayed_work(some_delayed_work, 0)? The result is the same, I just would like to know what is preferred so next time when workqueues are rewritten ;-) we have fewer troubles. Thanks, Jiri -- Jiri Benc SUSE Labs - To unsubscribe from this list: send the line "unsubscribe netdev" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html