On 12/22/18 9:51 PM, Heiner Kallweit wrote:
> On 22.12.2018 00:35, Marek Vasut wrote:
>> Add driver for the NXP TJA1100 and TJA1101 PHYs. These PHYs are special
>> BroadRReach 100BaseT1 PHYs used in automotive.
>>
>> Signed-off-by: Marek Vasut <ma...@denx.de>
>> Cc: Andrew Lunn <and...@lunn.ch>
>> Cc: Florian Fainelli <f.faine...@gmail.com>
>> Cc: Heiner Kallweit <hkallwe...@gmail.com>
>> ---
>> V2: - Use phy_modify(), phy_{set,clear}_bits()
>>     - Drop enable argument of tja11xx_enable_link_control()
>>     - Use PHY_BASIC_T1_FEATURES and dont modify supported/advertised
>>       features in config_init callback
>>     - Use genphy_soft_reset() instead of opencoding the reset sequence.
>>     - Drop the aneg parts, since the PHY datasheet claims it does not
>>       support aneg
>> V3: - Replace clr with mask
>>     - Add hwmon support
>>     - Check commstat in tja11xx_read_status() only if link is up
>>     - Use PHY_ID_MATCH_MODEL()
>> ---
>>  drivers/net/phy/Kconfig       |   6 +
>>  drivers/net/phy/Makefile      |   1 +
>>  drivers/net/phy/nxp-tja11xx.c | 424 ++++++++++++++++++++++++++++++++++
>>  3 files changed, 431 insertions(+)
>>  create mode 100644 drivers/net/phy/nxp-tja11xx.c
> [...]
>> +static int tja11xx_hwmon_read(struct device *dev,
>> +                          enum hwmon_sensor_types type,
>> +                          u32 attr, int channel, long *value)
>> +{
>> +    struct phy_device *phydev = dev_get_drvdata(dev);
>> +    int ret;
>> +
>> +    switch (attr) {
>> +    case hwmon_in_lcrit_alarm:
>> +            ret = phy_read(phydev, MII_INTSRC);
>> +            if (ret < 0)
>> +                    return ret;
>> +
>> +            *value = !!(ret & MII_INTSRC_TEMP_ERR);
>> +            return 0;
>> +    case hwmon_temp_crit_alarm:
>> +            ret = phy_read(phydev, MII_INTSRC);
>> +            if (ret < 0)
>> +                    return ret;
>> +
>> +            *value = !!(ret & MII_INTSRC_TEMP_ERR);
>> +            return 0;
>> +    default:
>> +            return -EOPNOTSUPP;
>> +    }
>> +}
> This looks like a copy & paste error, in both cases you're doing the same.

Fixed, thanks. I'll send V4 once I can actually test this stuff.

-- 
Best regards,
Marek Vasut

Reply via email to