On 11/14/06, David Miller <[EMAIL PROTECTED]> wrote:
From: "Eric Lemoine" <[EMAIL PROTECTED]>
Date: Mon, 13 Nov 2006 00:11:49 +0100

> +#if GEM_INTERRUPT_LOCKLESS
> +
> +/* Bitmask representing the interrupt conditions that we clear using 
GREG_IACK.
> + * We clear all the top-level interrupt conditions (bits 0 through 6) that we
> + * handle.
> + */
> +#define GREG_STAT_IACK               (GREG_STAT_NAPI & 0x3f)
> +#endif

I'm asking for this a second time...  and to be honest I'm a little
bit ticked off.

Please spell out the explicit bits using the existing defines to
create this mask.  Do not use this magic 0x3f magic number which
contains bits which are undefined, so obtain this mask (as I asked the
first time) like this:

        (GREG_STAT_TXINTME | GREG_STAT_TXALL |
         GREG_STAT_TXDONE | GREG_STAT_RXDONE |
         GREG_STAT_RXNOBUF)

I will not go through the effort a third time, instead I will simply
ignore your patch submissions, it's that simple.  If you ignore me, I
ignore you.

Dave, please believe me, I'm not ignoring you at all! I'm just trying
to make things better.

I had thought that:

(GREG_STAT_NAPI & 0x3f)

was better than

(GREG_STAT_TXINTME | GREG_STAT_TXALL |
GREG_STAT_TXDONE | GREG_STAT_RXDONE |
GREG_STAT_RXNOBUF)

because it makes it explicit that only bits 0 through 6 are taken into
account when writing the IACK register. In addition,  GREG_STAT_IACK
doesn't need to be changed if GREG_STAT_NAPI is changed. That's why I
did it that way. And as opposed to what I did in the previous patch, I
no longer set bits that don't exist with this new macro.

If you don't like it, let's discuss, and I can change my mind. But
again, please, do not think I'm ignoring your comments.

Thanks,

--
Eric
-
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to