The patchset has a few improvements on bpf_func_info: 1. Improvements on the behaviors of info.func_info, info.func_info_cnt and info.func_info_rec_size. 2. Name change: s/insn_offset/insn_off/
Please see individual patch for details. Martin KaFai Lau (4): bpf: Improve the info.func_info and info.func_info_rec_size behavior bpf: Change insn_offset to insn_off in bpf_func_info bpf: tools: Sync uapi bpf.h for the name changes in bpf_func_info bpf: Expect !info.func_info and insn_off name changes in test_btf/libbpf/bpftool include/uapi/linux/bpf.h | 2 +- kernel/bpf/core.c | 2 +- kernel/bpf/syscall.c | 46 +++++++++++--------------- kernel/bpf/verifier.c | 18 +++++----- tools/bpf/bpftool/prog.c | 7 ++++ tools/bpf/bpftool/xlated_dumper.c | 4 +-- tools/include/uapi/linux/bpf.h | 2 +- tools/lib/bpf/btf.c | 12 +++---- tools/testing/selftests/bpf/test_btf.c | 8 ++++- 9 files changed, 54 insertions(+), 47 deletions(-) -- 2.17.1