This patch set adds ABI versioning and documentation to libbpf. Patch 1 renames btf_get_from_id to btf__get_from_id to follow naming convention. Patch 2 adds version script and has more details on ABI versioning. Patch 3 adds simple check that all global symbols are versioned. Patch 4 documents a few aspects of libbpf API and ABI in dev process.
v1->v2: * add patch from Martin KaFai Lau <ka...@fb.com> to rename btf_get_from_id; * add documentation for libbpf API and ABI. Andrey Ignatov (3): libbpf: Add version script for DSO libbpf: Verify versioned symbols libbpf: Document API and ABI conventions Martin KaFai Lau (1): libbpf: Name changing for btf_get_from_id tools/bpf/bpftool/map.c | 4 +- tools/bpf/bpftool/prog.c | 2 +- tools/lib/bpf/Makefile | 23 +++- tools/lib/bpf/README.rst | 139 +++++++++++++++++++++++++ tools/lib/bpf/btf.c | 2 +- tools/lib/bpf/btf.h | 2 +- tools/lib/bpf/libbpf.map | 121 +++++++++++++++++++++ tools/testing/selftests/bpf/test_btf.c | 2 +- 8 files changed, 287 insertions(+), 8 deletions(-) create mode 100644 tools/lib/bpf/README.rst create mode 100644 tools/lib/bpf/libbpf.map -- 2.17.1