On Tue, Sep 18, 2018 at 06:52:34AM +0200, Mauricio Vasquez B wrote: > In the following patches queue and stack maps (FIFO and LIFO > datastructures) will be implemented. In order to avoid confusion and > a possible name clash rename stackmap.c to stacktracemap.c and > stack_map_ops to stack_trace_map_ops > > Signed-off-by: Mauricio Vasquez B <mauricio.vasq...@polito.it> > --- > include/linux/bpf_types.h | 2 > kernel/bpf/Makefile | 2 > kernel/bpf/stackmap.c | 624 > -------------------------------------------- > kernel/bpf/stacktracemap.c | 624 > ++++++++++++++++++++++++++++++++++++++++++++ > 4 files changed, 626 insertions(+), 626 deletions(-) > delete mode 100644 kernel/bpf/stackmap.c > create mode 100644 kernel/bpf/stacktracemap.c
Just new file for stack/queue will be enough. I understand that unfortunate name confusion, but this is too late. It will cause all sorts of headaches in fixes that go to net/stable.