On Thu, Sep 6, 2018 at 12:59 AM Vlad Buslov <vla...@mellanox.com> wrote: > > Functions tcf_block_get{_ext}() and tcf_block_put{_ext}() actually > attach/detach block to specific Qdisc besides just taking/putting > reference. Rename them according to their purpose.
Where exactly does it attach to? Each qdisc provides a pointer to a pointer of a block, like &cl->block. It is where the result is saved to. It takes a parameter of Qdisc* merely for read-only purpose. So, renaming it to *attach() is even confusing, at least not any better. Please find other names or leave them as they are.