On 12/05/2017 05:46 PM, tristram...@microchip.com wrote: > From: Tristram Ha <tristram...@microchip.com> > > This series of patches is to modify the original KSZ9477 DSA driver so > that other KSZ switch drivers can be added and use the common code. > > There are several steps to accomplish this achievement. First is to > rename some function names with a prefix to indicate chip specific > function. Second is to move common code into header that can be shared. > Last is to modify tag_ksz.c so that it can handle many tail tag formats > used by different KSZ switch drivers. > > ksz_common.c will contain the common code used by all KSZ switch drivers. > ksz9477.c will contain KSZ9477 code from the original ksz_common.c. > ksz9477_spi.c is renamed from ksz_spi.c. > ksz9477_reg.h is renamed from ksz_9477_reg.h. > ksz_common.h is added to provide common code access to KSZ switch > drivers. > ksz_spi.h is added to provide common SPI access functions to KSZ SPI > drivers.
Is something gating this series from getting included? It's been nearly 8 months now and this has not been include nor resubmitted, any plans to rebase that patch series and work towards inclusion in net-next when it opens back again? Thank you! > > v2 > - Initialize reg_mutex before use > - The alu_mutex is only used inside chip specific functions > > v1 > - Each patch in the set is self-contained > - Use ksz9477 prefix to indicate KSZ9477 specific code > > Tristram Ha (8): > Replace license with GPL. > Clean up code according to patch check suggestions. > Initialize mutex before use. > Rename some functions with ksz9477 prefix to separate chip specific > code from common code. > Rename ksz_spi.c to ksz9477_spi.c and update Kconfig in preparation to > add more KSZ switch drivers. > Break KSZ9477 DSA driver into two files in preparation to add more KSZ > switch drivers. Add common functions in ksz_common.h so that other > KSZ switch drivers can access code in ksz_common.c. Add ksz_spi.h > for common functions used by KSZ switch SPI drivers. > Prepare PHY for proper advertisement and get link status for the port. > Rename ksz_9477_reg.h to ksz9477_reg.h for consistency as the product > name is always KSZ####. > > drivers/net/dsa/microchip/Kconfig | 12 +- > drivers/net/dsa/microchip/Makefile | 4 +- > drivers/net/dsa/microchip/ksz9477.c | 1331 > ++++++++++++++++++++ > .../microchip/{ksz_9477_reg.h => ksz9477_reg.h} | 23 +- > drivers/net/dsa/microchip/ksz9477_spi.c | 188 +++ > drivers/net/dsa/microchip/ksz_common.c | 1176 +++-------------- > drivers/net/dsa/microchip/ksz_common.h | 229 ++++ > drivers/net/dsa/microchip/ksz_priv.h | 256 ++-- > drivers/net/dsa/microchip/ksz_spi.c | 216 ---- > drivers/net/dsa/microchip/ksz_spi.h | 82 ++ > 10 files changed, 2122 insertions(+), 1395 deletions(-) > create mode 100644 drivers/net/dsa/microchip/ksz9477.c > rename drivers/net/dsa/microchip/{ksz_9477_reg.h => ksz9477_reg.h} (98%) > create mode 100644 drivers/net/dsa/microchip/ksz9477_spi.c > create mode 100644 drivers/net/dsa/microchip/ksz_common.h > delete mode 100644 drivers/net/dsa/microchip/ksz_spi.c > create mode 100644 drivers/net/dsa/microchip/ksz_spi.h > -- Florian