On 12/27/17 1:57 AM, Leon Romanovsky wrote:
> From: Leon Romanovsky <leo...@mellanox.com>
> 
> Hi,
> 
> The following patchset comes as a preparation to more complex code,
> which will add resource tracking visibility to the rdmatool, where
> the kernel part is under review of RDMA community.
> 
> Thanks
> 
> [1] https://marc.info/?l=linux-rdma&m=151412508816802&w=2
> 
> Leon Romanovsky (10):
>   rdma: Reduce scope of _dev_map_lookup call
>   rdma: Protect dev_map_lookup from wrong input
>   rdma: Move per-device handler function to generic code
>   rdma: Fix misspelled SYS_IMAGE_GUID
>   rdma: Check that port index exists before operate on link layer
>   rdma: Print supplied device name in case of wrong name
>   rdma: Get rid of dev_map_free call
>   rdma: Rename free function to be rd_cleanup
>   rdma: Rename rd_free_devmap to be rd_free
>   rdma: Move link execution logic to common code
> 
>  rdma/dev.c   |  28 +----------------
>  rdma/link.c  |  51 +++---------------------------
>  rdma/rdma.c  |   7 ++---
>  rdma/rdma.h  |   5 +--
>  rdma/utils.c | 100 
> ++++++++++++++++++++++++++++++++++++++++++++++++++++-------
>  5 files changed, 100 insertions(+), 91 deletions(-)
> 
> --
> 2.15.1
> 


Applied to net-next. Thanks, Leon.

Reply via email to