On Thu, Nov 02, 2017 at 10:54:12AM -0700, Joe Perches wrote: > On Thu, 2017-11-02 at 13:15 -0400, Roman Gushchin wrote: > > Rename device type and access type constants defined in > > security/device_cgroup.c by adding the DEVCG_ prefix. > > > > The reason behind this renaming is to make them global namespace > > friendly, as they will be moved to the corresponding header file > > by following patches. > [] > > diff --git a/security/device_cgroup.c b/security/device_cgroup.c > [] > > @@ -14,14 +14,14 @@ > > #include <linux/rcupdate.h> > > #include <linux/mutex.h> > > > > -#define ACC_MKNOD 1 > > -#define ACC_READ 2 > > -#define ACC_WRITE 4 > > -#define ACC_MASK (ACC_MKNOD | ACC_READ | ACC_WRITE) > > +#define DEVCG_ACC_MKNOD 1 > > +#define DEVCG_ACC_READ 2 > > +#define DEVCG_ACC_WRITE 4 > > +#define DEVCG_ACC_MASK (DEVCG_ACC_MKNOD | DEVCG_ACC_READ | DEVCG_ACC_WRITE) > > trivia: > > major and minor are u32 but all the > type and access uses seem to be "short" > > Perhaps u16 (or __u16 if uapi public) instead?
It was so for a while, and it doesn't seem to be related with this patchset. So, I'd prefer to change this in a separate patch. Thanks!