Jiong says:

  Compilers are starting to use BPF_NEG, for example LLVM. However, NFP
does not support JITing it. This patch set adds this. Unit test is added
as well.

  Meanwhile, the current NFP_ALU_NEG is actually doing bitwise NOT (one's
complement) operation, so the name is misleading. This patch set corrects
this.


Jiong Wang (2):
  nfp: bpf: rename ALU_OP_NEG to ALU_OP_NOT
  nfp: bpf: support [BPF_ALU | BPF_ALU64] | BPF_NEG

 drivers/net/ethernet/netronome/nfp/bpf/jit.c | 26 +++++++++++++++++++++++++-
 drivers/net/ethernet/netronome/nfp/nfp_asm.h |  2 +-
 2 files changed, 26 insertions(+), 2 deletions(-)

-- 
2.14.1

Reply via email to