On Thu, Sep 21, 2017 at 09:29:33PM +0200, Daniel Borkmann wrote: > On 09/21/2017 06:58 PM, Edward Cree wrote: > > On 21/09/17 17:40, Y Song wrote: > > > On Thu, Sep 21, 2017 at 9:24 AM, Edward Cree <ec...@solarflare.com> wrote: > > > > On 21/09/17 16:52, Alexei Starovoitov wrote: > > > > > imo > > > > > (u16) r4 endian be > > > > > isn't intuitive. > > > > > Can we come up with some better syntax? > > > > > Like > > > > > bswap16be r4 > > > > > bswap32le r4 > > > > Hmm, I don't like these, since bswapbe is a swap on *le* and a nop on > > > > be. > > Agree, a bit too much 'swap' semantics in the name that could be > confusing perhaps, at least the be/le could be missed easily. > > > > > > or > > > > > > > > > > to_be16 r4 > > > > > to_le32 r4 > > > > And the problem here is that it's not just to_be, it's also from_be. > > More intuitive, but agree on the from_be/le. Maybe we should > just drop the "to_" prefix altogether, and leave the rest as is since > it's not surrounded by braces, it's also not a cast but rather an op.
'be16 r4' is ambiguous regarding upper bits. what about my earlier suggestion: r4 = (be16) (u16) r4 r4 = (le64) (u64) r4 It will be pretty clear what instruction is doing (that upper bits become zero).